QR code per la pagina originale

Il vincolo delle estensioni di Firefox

,

Le estensioni (o add on o componenti aggiuntive) di Firefox sono con tutta probabilità la più grande innovazione portata dal browser di Mozilla. I loro pregi sono infiniti e vanno dal livello più superficiale di costituire uno strumento di fidelizzazione di sviluppatori e utenti a quello più profondo di essere un banco di prova per funzioni da integrare nelle versioni successive del browser, un laboratorio di idee gigantesco che si avvale di collaboratori in tutto il mondo.

Insomma non è difficile decantare le lodi delle estensioni Firefox, non nascondo che sono il motivo principale (ma non l’unico) per cui mi avvalgo del browser Mozilla, eppure non posso fare a meno di pensare che siano anche un grosso handicap.

Io per esempio vorrei moltissimo cominciare ad usare le nuove release beta di Firefox 3, le migliorie sono tali e tante (e talmente necessarie!) che in altri casi l’avrei già scaricato da parecchio. Eppure non lo faccio e so che non lo farò ancora per un bel po’ perchè le estensioni non sono compatibili: ho fatto un controllo e quelle più fondamentali (per me) non sono compatibili con la versione 3. E non ci posso rinunciare, ormai ne sono drogato.

E poi ne ho installate talmente tante che pensare di rimettermi a cercarle e scaricarle di nuovo è un vero lavoro. Insomma non mi va di passare alla versione successiva per non perdere le mie estensioni e non mi riesce difficile pensare che sia lo stesso per molti altri utenti.
Mi tocca aspettare che i singoli sviluppatori mettano a punto una versione successiva compatibile con Firefox 3, e se non lo fanno? E poi sono così tanti che prima che lo facciano tutti…

Insomma il problema non è facilmente risolvibile e al di là delle piccole beghe personali mi sembra che ci sia una sacca di resistenza all’aggiornamento alla nuova versione che trova ottime motivazioni nel non voler perdere le proprie estensioni, in alcuni casi fondamentali per lavorare e in altre fondamentali per vivere!!